SocialEngine 4: Storage_File Problems

Have you ever been browsing through your Social Site and all of a sudden you have lost all the Content from Profile images to News Feeds even having site errors when trying to access any of your plugins.

Have you seen this error within your Error Log?

exception 'Engine_Api_Exception' with message 'Unknown item type: storage_file' in /home/mysite/domains/mysite.com/public_html/application/libraries/Engine/Api.php:393

If this is the same or very close to the error you had then the fix can be very easy.

If you open your SQL Database and locate Table ” engine4_core_modules ”

Once you have open the table scroll to the bottom of the page and locate table ” Storage ” if you move 4 Columns over and you should see a number 0 in the column change that number to 1 and save.

If you now return to your website and refresh the page everything should now be back to normal.

Looking for quality Social Engine Web Hosting? Look no further than Arvixe Web Hosting!

Tags: , , , , , , , , , , , , | Posted under SocialEngine | RSS 2.0

Author Spotlight

Andrew Cross

Andrew Cross

Hi, I'm Andrew. A am a 25, ICT Administrator which offers support to company's around the South Wales Area. I have created a few social sites for myself and other company's. So far 2 out of 3 have been successful using the powerful SocialEngine Script. I continue to try and help the community of SocialEngine by giving Support and Technical Help where possible.

2 Comments on SocialEngine 4: Storage_File Problems

  1. How’s Andrew

    Dude, I been stressing over this the last two days. This worked for me no issues. Please continue blogging bro.
    Two quick question however; In my situation this has always been working then suddenly it changed without any explicit fiddling from me and my team, what caused the change in the first place? (1) and (2) what can I look out for in the future to avoid a situation like this?
    Many thanks again,

  2. Andrew Cross Andrew Cross says:

    Hi thabiso,

    At this moment intime i do not know what can cause this problem.

    I tend to do optimize my database each month to help the smooth running of database and site.

Leave a Reply

Your email address will not be published. Required fields are marked *


6 + = 12

You may use these HTML tags and attributes: <a href="" title="" rel=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>