How to Use PHP 5.3 on Linux Hosting

There is a new way to do this. Please follow the instructions at this link:

http://blog.arvixe.com/change-php-version-using-the-php-version-manager/

The release of PHP 5.3.x is a major improvement in the 5.x series which includes a large number of new features and bug fixes.

By default, our Linux accounts makes use of PHP 5.2 as not all scripts are compatible with PHP 5.3, but if you are ready to make the jump. or your script requires PHP 5.3; you can do the following:

Adding to your existing .htaccess file in your public_html directory or creating one if it doesn’t already exist; add the following contents to the top of the file:

AddHandler application/x-httpd-php53 .php

Save the file and you should now be on PHP 5.3 If you are still facing, please submit a ticket to our support department from support.arvixe.com and our support staff would be happy to help you out.
Arvixe, the pioneer in the web hosting industry, attempts to always provide current and future customers with the most cutting-edge technology to support their applications and needs. Therefore, Arvixe is proud to be amongst one of very few hosts to offer and support php 5.3 across all linux servers. New to Extensions, Modules, and Libraries? Learn more about PHP 5.3, then purchase a web hosting account from Arvixe and get going in minutes. PHP 5.3 not for you? We have many more Extensions, Modules, and Libraries solutions: Extensions, Modules, and Libraries hosting

Looking for quality PHP 5.3 Web Hosting?  Look no further then Arvixe Web Hosting

Tags: , , | Posted under PHP.ini | RSS 2.0

6 Comments on How to Use PHP 5.3 on Linux Hosting

  1. Ouija says:

    I tried enabling PHP 5.3 as per the instructions (adding the line to my .htaccess file) however, the server no longer renders pages and just tries to download the index.php (or whatever .php file I am trying to view) instead. Any ideas?

  2. Mark says:

    I also have the problem where after you modify “.htaccess” it wants to download all .php files rather than actually executing them. My only guess would be that apache may need to be reset or the cache cleared. It is very peculiar.

  3. Ryan C says:

    That means that PHP 5.3 is not yet enabled at our server level in Apache if it downloads the PHP files. Simply submit a support ticket and our staff can get that installed and enabled for you. It is still missing from our legacy servers.

  4. Melissa says:

    As of Jan 2, 2012, this problem still exists. Just wasted a whole day dealing with various “bugs” to finally learn that the problem is arvixe’s and that it is a problem that they have publicly admitted exists for two months.

  5. Faissal says:

    Melissa, I have to disagree. They might get stuck sometimes, but I noticed improvement in service and technical environment as well. After contacting Arvixe yesterday about Date diff working only on >=5.3, first I was advised to the post above, then after telling them it still doesn’t work they said:

    cite start === Thank you for holding on , It appears PHP 5.3 support is not enabled on server ‘rhino.arvixe.com’ , I have taken this to the attention of senior admin so they compile PHP 5.3 on server. Please note that it may take 12~24 hours , We’ll update you once PHP 5.3 support will be enabled on server.=== cite end

    It really did not take more than 12 hours (It could have been faster, but glad it went well) and it is updated.

    Thanks Arvixe

  6. devananda says:

    thanks for this support. pasting this on the very top of a joomla .htaccess file allows for the latest php. And in moodle I had to create a .htaccess file in cpanel and just name it .htaccess and then paste this code there.

    Arvixe support is really great!

    Sincerely,

Leave a Reply

Your email address will not be published. Required fields are marked *


+ 9 = 18

You may use these HTML tags and attributes: <a href="" title="" rel=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>